Configure E-mail notification not working


#1

Hello,

I am configuring Globaleaks on a Ubuntu VPS but the e-mail configuration is not working. Can’t connect it with my preffered e-mail address. Any idea why? Using the standard firewall on Ubuntu. Open ports are:

80/tcp ALLOW Anywhere
8082/tcp ALLOW Anywhere
22/tcp ALLOW Anywhere
443 ALLOW Anywhere
465 ALLOW Anywhere
993 ALLOW Anywhere
995 ALLOW Anywhere
587 ALLOW Anywhere
143 ALLOW Anywhere
110 ALLOW Anywhere

Is firewall blocking something?

Thanks in advance.


#2

Hello @Raf_Rasenberg,

GlobaLeaks comes with a default configuration that enable to send email via our SMTP server with a secure confiugration in relay mode that do not store any of the sent email.

You could change that configuration with the configuration of your server but in this case you need:

  • a configured SMTP server on your control (we may advise on best configurations)
  • you should create a user account (mailbox) and configure its usenrame/password/etc on GlobaLeaks

Please let us know if something is not clear.

best,

Giovanni Pellerano


#3

@evilaliv3 Aah thank you so the settings that were pre defined where already correct? But how can you interact with a whistle blower then? Does the communication go through the online portal?

And can you send me the correct SMTP settings then for using your SMTP server, I deleted those right now


Configurazione ed altri quesiti configurazione whistleblowing anticorruzione 179/2017 e 190/2012
#4
  • Yes the default is fully working
  • Email are used only for notifications of new submissions and new content but they do not contain any sensitive information.
  • Communications whith the whistleblower happens via comments on the online portal.

These are the default settings:

u’smtp_server’: Unicode(default=u’demo.globaleaks.org’),
u’smtp_port’: Int(default=9267),
u’smtp_username’: Unicode(default=u’hey_you_should_change_me’),
u’smtp_password’: Unicode(default=u’yes_you_really_should_change_me’),
u’smtp_source_name’: Unicode(default=u’GlobaLeaks - CHANGE EMAIL ACCOUNT USED FOR NOTIFICATION’),
u’smtp_source_email’: Unicode(default=u’notification@demo.globaleaks.org’),
u’smtp_security’: Unicode(default=u’TLS’),
u’smtp_authentication’: Bool(default=True),


#5

Where can I find those settings to edit them?? I was only talking about the notifications settings in the admin panel. I changed them to my e-mail address so I could receive notifications but now the portal says:

This server is not configured.

You will not be able to send a submission.

Honestly its a bit confusing, does the admin panel settings change the default mail settings or is it purely for notifications? Because the panel doesn’t work anymore now.


#6

I just messed some things up how can I delete globaleaks from command line and do fresh install? Do you know the command?