Error on input validation [need at least one recipient]


#1

Hello!

We are doing some test in our globaleaks platform, but when with want to submit something we got an error that says: Error on input validation [need at least one recipient]

We now have three users: 2 recipients and 1 admin.

Any ideas on how to solve this?Captura%20de%20pantalla%20de%202018-05-31%2015-20-07


#2

Hello @david,

by default the platform was configured with a context and a recipient assigned.
I expected that while you were configuing your recipients you tweaked the Context onfiguration removing the option “Select all the recipients by default”

Look inside the context configuration and enable this option.

From what i see in fact ou are not offering the whistleblower the possibility to select individual recipients and on this situations recipients should be all automatically selected.

Mine is just a guess but this is likely the cause of your failure.


#3

Hello @evilaliv3

Thanks for your reply im looking at the context section and i dont see de option “Select all the recipients by default”

Any idea?

thanksCaptura%20de%20pantalla%20de%202018-05-31%2015-55-56


#4

The option "Select all recipients by default " is a suboption that you see if you enable the whistleblower to select its recipients.

I guess you enabled this option, removed select all recipients and then you re-disabled the option.

To fix, enable the whistleblower to select recipients, re-enable the option select all recipients by default and then disable again the whisleblower to select their recipients.

Please let us know if this will fix your issue!


#5

Hello.
Sorry for the long delay in the answer. I try what you told me, but not sure if i understood, what do you mean with:
-re-disable this option
-re enable the option (which option)

thanks!


#6

The two options that i envision to be bad set are:

  • Allow whistleblower to select their recipients
  • Select all recipients by default

To fix i suggest you to try:

  1. Enable “Allow the whistleblower to select their recipientes” that is currently disabled
  2. This will allow you to see “Select all recipients by default” that you probably disabled for error. Enable it again.
  3. Then you may disable again “Allow the whistleblower to select their recipientes” enabled in step 1

#7

Hi.

Thanks for your support. i made the changes you suggest but i get the same error. Attach you an image.Captura%20de%20pantalla%20de%202018-06-06%2013-11-07

Any other ideas?


#8

Hi,

I have the same problem with a fresh installation of GL.
I also have two recipients but no at every option (select just one or both) I receive the same error.
Could you fix it?


#9

Hello @lokamule,

i think you both configured the platform to accept only submissions when users are configured with a PGP key.

To fix you should either disable that option in the advanced settings or load a PGP key for your users.

best,

Giovanni Pellerano


#10

Thanks. It was also fixed when I added the PGP keys to my users.