Errore di validazione nell'input - need at list one recipient


#1

Buongiorno, ho installato e configurato il sistema per il mio Ente.

Ho questo problema. Quando vado ad inviare un segnalazione mi esce l’errore in oggetto:

1 - ho inserito un ricevente
2 - contesto ho cancellato i default ed aggiunto il mio ente
3 fatto nuovo questionario ed eliminato il default
4 assegnato il questionario al contesto.

Cosa potrebbe essere?

2 Non c’è la possibilità di riportare la configurazione ad una impostazione iniziale?

Grazie.


#2

Nelle impostazioni del “Contesto” è necessario associare un utente receiver, che in questo caso si vede che non è attivato. Potrebbe dare una occhiata a quella impostazione e farci sapere se si tratta di questo setting?

Saluti
Fabio Pietrosanti


#3

Buongiorno,
anche io, come l’utente che ha aperto questo thread, ho configurato GlobaLeaks ed ho lo stesso problema. Confermo di aver creato un utente receiver e di averlo associato al contesto.
Ho creato un nuovo contesto, un nuovo questionario, ho configurato le impostazioni per le notifiche (ricevo correttamente l’email di test.
Cosa potrebbe mancare nella configurazione ?
Grazie per le informazioni


#4

Salve,

è possibile vedere uno screenshots della associazione del nuovo utente-contesto e/o indirizzo web per dare una occhiata alla configurazione dalla interfaccia pubblica?

Nel caso se vuoi venire in chat su https://slack.hermescenter.org ci confrontiamo e facciamo una diagnostica per capire cosa non vada, in teoria fintanto che il contesto c’è, ha un questionario e un ricevente associato, non dovrebbe in alcun modo dare quel tipo di errore (ma magari è un bug?).

Fabio


#5

Buongiorno Fabio,
purtroppo il portale non è ancora pubblico. Inserendo due receiver “compare” un passo aggiuntivo per la scelta del receiver quindi credo siano configurati correttamente. Allego screenshot del backend
Mi sono collegato a slack, quindi quando lo desidera possiamo sentirci anche lì
Grazie
MichelecontestoConRiceventiAssociati


#6

Buongiorno @mlonghini

La ringrazioamo per il feedback fornito.

Stiamo provvedendo ad alcune verifiche e le faremo sapere appena avremo qualche informazione aggiuntiva.


#7

Buongiorno
anche noi abbiamo lo stesso problema.
Appena installato alcuni mesi fa funzionava tutto.
Da qualche settimana c’è l’errore indicato.
il sito è: segnalazioni.commerfidi.it

grazie


#8

Suppongo abbiate configurato il nodo per inibire le segnalazioni nel caso non siano caricate le chiavi PGP di crittografia per ciascun utente.

Potete disabilitare questa opzione e tutto riprendera’ a funzionare anche senza che le chiavi siano caricate e questo dovrebbe potervi consentire di andare avanti con le vostre prove.

Entro qualche settimana verra rilasciato un aggiornamento di sicurezza che rendera’ le chiavi non necessarie per effettuare crittografia sia sui file sia sui dati delle segnalazioni quindi qualora non abbiate ancora analizzato gli aspetti crittografici in merito a PGP, potete sorvolare l’argomento ed attendere il prossimo aggiornamento che sara incluso a partire dal rilascio 3.4.0


#9

E’ vero, adesso funziona tutto.
Grazie!