Globaleaks error after upgrade to 3.11.12

Hi all! I’m new at forum and about globaleaks. Yesterday i’ve upgraded to globaleaks 3.11.12 and now i have this error when i try with firefox to go to the webpage:

SSL_ERROR_NO_CYPHER_OVERLAP

How can i avoid this error?
Now i see that there is an update 3.11.15, maybe i try to update again.
Thank you.

Stefano

Hello @stezani,

with the recent updates we have improved the security of the SSL configuration but it is possible that some compatibility issues have been introduced.

Would you please share me a link to the platform and clarify me which browser are you using?

Do you verify this inconvenience with every browser?
Have you tried to reset your browser?

best,

Giovanni Pellerano

Hi Giovanni,

this is the link: https://wb.lepida.it/

I’m using Firefox 60.0 64bit on Fedora 27. I have the same error under Chrome.

Stefano

Are you using any application protection software/antivirus such as Bitdefender that’s also doing TLS MITM inspection and cause such kind of issues?

Was reading https://support.mozilla.org/en-US/questions/1240398

I am getting ERR_SSL_VERSION_OR_CIPHER_MISMATCH on Chrome Version 77.0.3865.90 (Official Build) (64-bit) on Mac OS X on https://wb.lepida.it/

@fpietrosanti: actually this is not related. If you visit the provided url you will see that the issue is general (wb.lepida.it)

@stezani; which operating system/version are you running? which is the version of openssl that is installed on the system?

I’m running Fedora 27 on my machine, and globaleaks is installed on Ubuntu 18.04.2. My openssl version is 1.1.0h-fips 27 Mar 2018

@stezani: the issue is related to the server only.

Would you please clarify me if the version of openssl that you mentioned is the one of the server or of your fedora?

The openssl version is on my fedora

I see. Which is the openssl version on the globaleaks Ubuntu?

Would you please take the system to the latest updates with “apt-get update && apt-get upgrade”, restart globaleaks and let me know if the issue persists?

The OpenSSL version on Ubuntu is
1.1.0g 2 Nov 2017

Now i try to update

Ok i have update Ubuntu and restarted globaleaks but still not working

Wait: now i can access via http://wb.lepida.it/. Now globaleaks tell me to set a new admin password.

Ok now it works. After ubuntu upgrade now i can open the site via https. Thank you!

you are welcome @stezani

@stezani: by any chance do you have the log of the packages/versions that have been updated when you updated the Ubuntu Server?

We are trying to identify which was the component that was causing the failure.

Eventually would you please annotat it here?

thank you!

Giovanni

Possibly same cause as this issue?

ssl-error-after-update-to-3-11-15