LetsEncrypt Certificate


#1

Hello
I tried to activate the https service with automatic configuration of LetsEncrypt. After accepting the conditions and pressing the button proceed the system tells me:
Internal server error and does not enable https
These are some rows of logs:

2018-08-28 10:29:16+0000 [-] [E] acme.messages.Error ACME error.\n\n https://tools.ietf.org/html/draft-ietf-appsawg-http-problem-00\n&#9$
2018-08-28 10:29:16+0000 [-] [-] [1] 500 PUT /admin/config/acme/run 99B 1030ms

Please help me thanks


#2

Some questions for preliminary analysis:

a) Which version of GlobaLeaks are you using?

b) Which version of Ubuntu are you using (16.04 or 18.04) ?

c) Does the server have some kind of firewall blocking inbound or outbound connections?


#3

GlobaLeaks version: 3.3.11
Database version: 43

Ubuntu 18.04

ufw is disable


#4

Could you:

  1. Post the full stack of the “globaleaks.log” last 15-20 lines of log, to see if there’s something to make debugging easier to be understood.

  2. Post, also privately, the hostname your are trying to configure (to understand if there’s some error there)

/cc @evilaliv3


#5

Is your server reachable from the internet on port 80 and port 443 on the hostname you are trying to configure?

Looking from some unhandled errors we got on the debug-dev environment, if it it’s Monselice, the hostname doesn’t seems to be reachable from the internet, so the LetsEncrypt servers cannot reach it and the entire certificate activation process die with acme.errors.ValidationError .


#6

I wrote you an email in response to the previous topic, I gave you the domain name.
You’re right from the outside is not reachable. I check the configuration!!!