Open Globalleaks outside 127.0.0.1

#1

Hello i’ve installed globalleaks , from ubuntu desktop all works fine, but if i try to reach it via LAN or Internet via Internal o Public IP the platform is not reachable… there is some config to do? it seems linux firewall set as OFF

0 Likes

#2

Have you already enabled HTTPS and enrolled a digital certificates for a configured hostname using LetsEncrypt?

If you wish, drop us an email and will setup a shared assistance group chat on Slack, to follow your installation step-by-step, so you can help us bugfixing the new major release of GlobaLeaks 2.70

0 Likes

#3

@Andrea the platform is already reachable on public ip on the default install.

The following are the connection possibilityies on a default setup:

127.0.0.1:8082 (local only for simulating connections from client non Tor)
127.0.0.1:8083 (local only for simulatin connections from Tor client)
0.0.0.0:80 and 0.0.0.0:443 for internet reachable connections via HTTP and HTTPS respectivelty
address.onion: for Tor accesses

0 Likes

#4

ok it works… the problem is the port… i tryed to reach outside from port 8082 and not 80…

thanks

0 Likes

#5

the only info for new version i this is make an how-to phase to phase …

for example into the file /etc/default/globaleaks i have added network sandboxing=0 ( i don’t know if is really required… )
i don’t find option to put into file…

and where are the globaleaks files and folder? into the developer setup i have a folder with Globaleaks appliance, backend, client, material but into the apt installed version i canno’t find this files

0 Likes

#6

Are you setting up development environment or a production installation?

0 Likes