Problemi con l'aggiornamento su Ubuntu 20.04

Buongiorno sto provando ad aggiornare globaleaks all’ultima versione in quanto negli ultimi 3-4gg mi sono arrivati degli exception del software via email.
Ma quando provo ad aggiornare mi da
apt update
Hit:1 http://archive.ubuntu.com/ubuntu focal InRelease
Get:3 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]
Get:4 http://archive.ubuntu.com/ubuntu focal-backports InRelease [101 kB]
Ign:2 https://deb.globaleaks.org bionic/ InRelease
Get:5 https://deb.globaleaks.org bionic/ Release [744 B]
Get:6 http://archive.ubuntu.com/ubuntu focal-updates/main Sources [383 kB]
Get:7 https://deb.globaleaks.org bionic/ Release.gpg [833 B]
Get:8 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Err:7 https://deb.globaleaks.org bionic/ Release.gpg
The following signatures were invalid: EXPKEYSIG 32E6792624045008 GlobaLeaks software signing key info@globaleaks.org
Get:9 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [947 kB]
Get:10 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [13.2 kB]
Get:11 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [763 kB]
Get:12 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 c-n-f Metadata [17.2 kB]
Fetched 2,449 kB in 1s (1,765 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
74 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: https://deb.globaleaks.org bionic/ Release: The following signatures were invalid: EXPKEYSIG 32E6792624045008 GlobaLeaks software signing key info@globaleaks.org
W: Failed to fetch http://deb.globaleaks.org/bionic/Release.gpg The following signatures were invalid: EXPKEYSIG 32E6792624045008 GlobaLeaks software signing key info@globaleaks.org
W: Some index files failed to download. They have been ignored, or old ones used instead.

Come posso risolvere ?
Claudio

@soprano

Es possibile un problema de installare i pacchetti GlobaLeaks per bionic (18.04), en un sistema focale (20.04).

Scrivi

deb https://deb.globaleaks.org focal

en /etc/apt/sources.list o /etc/apt/sources.list/globaleaks

Ultima, continua con https://docs.globaleaks.org/en/devel/user/admin/UpgradeGuide.html?highlight=upgrade#upgrade-of-the-distribution-version

El chiave PGP pubblica por GlobaLeaks probabilmente è installato con

curl -L https://deb.globaleaks.org/globaleaks.asc | apt-key add

en
https://deb.globaleaks.org/install-globaleaks.sh
(che cosa es tuo modo normale per installati).

El chiave por la segnatura pacchetti es nel https://deb.globaleaks.org/focal/


Inglesi:

I think you are trying to install GlobaLeaks packages for bionic (18.04), on a focal (20.04) system.

Make sure it is

deb https://deb.globaleaks.org focal

in /etc/apt/sources.list or /etc/apt/sources.list/globaleaks

Then https://docs.globaleaks.org/en/devel/user/admin/UpgradeGuide.html?highlight=upgrade#upgrade-of-the-distribution-version

You will have gotten the public PGP signing key via

curl -L https://deb.globaleaks.org/globaleaks.asc | apt-key add

in
https://deb.globaleaks.org/install-globaleaks.sh
(if you installed it the regular way), so that should still be good :slight_smile:

The actual signature for the package is in https://deb.globaleaks.org/focal/ which it will look for when you upgrade the package address on your system