SSL deprecated?

Hi, after an upgrade, “HTTP Strict Transport Security (HSTS)” warn on browser and Code d’erreur : SEC_ERROR_EXPIRED_CERTIFICATE.
Is it problem with SSL key generation (acmeV1 deprecated) in your code ?

I found a solution, install third-party software (acme.sh) to generate ssl key and import though admin dashboard (via Tor lol). The functionality to generate automatically cert. is broken.

Thank you @jmb for your question.

Actually the current release of GlobaLeaks is known to be working correctly.

the failure you may be reporting is a know issue affecting releases <= 4.2.6: Letsencrypt renewal fails with multiple intermediate certificates on GL <= 4.2.6 · Issue #3006 · globaleaks/GlobaLeaks · GitHub

I invite you to update to latest version (current 4.2.10)

Hi evilaliv3,
Thanks for your quick response.
On another instance i’ve:
currently: globaleaks is already the newest version (4.2.12).
But in admin dashboard i read: “Version du logiciel : 3.10.4”
In log:
2021-07-21 15:28:47+0000 [-] Starting factory <Site object at 0x7f73b308a7c0>
2021-07-21 15:28:47+0000 [-] GlobaLeaks is now running and accessible at the following urls:
2021-07-21 15:28:47+0000 [-] - [HTTP] → http://xxxxxxx.xxxxx.org
2021-07-21 15:28:47+0000 [-] - [Tor]: → http://gjaczhxxkm4zbbtxxxxxxxxxxxxxxn2glad.onion
2021-07-21 15:28:48+0000 [-] [E] Successfully connected to Tor control port
SSL not working, (Installed manually on dashboard cause automatic failed)