Two factor autentication


#1

Buonasera

Provato su un’installazione in prova ad abilitare l’autenticazione a due fattori.

La e-mail non arriva … ma potrebbe essere un problema di errata configurazione dell’smtp server da parte nostra.

Il problema è: come si accede senza codice all’area di gestione (backoffice) per disabilitare la 2FA … se non si riesce a passare 2FA ?

grazie


#2

Gentile @zazzati,

in seguito alla sua segnalazione ho già analizzato in approfondito la sua problematica.

Il suo problema sarebbe in generale aggirabile con l’utility di sistema: gl-admin

tale utility permette di impostare variabili di configurazione ed ad esempio permette di resettare la configurazione 2FA emettendo il comando: gl-admin setvar two_factor_auth False

Ad ogni modo nel riprovare questo suggerimento ho identificato una problematica che riguarda l’uso di questo comando e le variabili booleane (True/False)

Ho gia emesso una patch (che se volesse può applicare manualmente) che sarà inserita entro oggi in un rilascio minore. Attenda la disponibilità della version 3.6.12 e potrà procedere con il comando menzionato sopra.

Cordialmente,

Giovanni Pellerano


#3

Abbiamo 3 istanze, attualmente, su server di test.

Ubuntu 18.04.1 LTS Release: 18.04

Il comando
apt-get update & apt-get install globaleaks
ha aggiornato alla 3.6.12 due istanze.

La terza rimane ferma a 3.6.7

Reading package lists… Done
Building dependency tree
Reading state information… Done
globaleaks is already the newest version (3.6.7).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Cosa possiamo verificare per convincere questa istanza ad aggiornarsi ?

grazie, saluti


#4

Gentile @zazzati,

immagino che fra i vari sistemi ci sia una diversità di versione di ubuntu ed è possibile che non avessimo ancora rilasciato il pacchetto aggiornato per una delle distribuzioni.

Può gentilmente riprovare separatamente apt-get update e apt-get update globaleaks?

In ogni caso le suggerirei di usare di usare per tutte le piattaforme la Ubuntu 18.04 che è la corrente LTS coperta dal nostro supporto ufficiale.

Per aggiornare la distribuzione tenga ben a riferimento questa guida che le da una procedura speciale in caso di Distribution upgrade che era particolarmente necessaria per la versione ubuntu Trusty, e che rimane una buona procedura in generale per ogni aggiornamento di versione di Ubuntu: http://docs.globaleaks.org/en/latest/UpgradeGuide.html

Cortesemente mi faccia pure sapere se ha risolto il problema.

cordialmente,

Giovanni Pellerano


#5

Ho provato a seguire la sua guida ma l’istanza è rimasta bloccata sulle 3.6.7

Ho provveduto a rimuovere (apt-get remove globaleaks) e reinstallare mediante script install-globaleaks.sh ed ora è disponibile sul server la 3.6.14

grazie, saluti