Upgrade 3.0.18 to 3.0.24 failed


#1

Hello, i have Ubuntu 16.04.3 LTS with 3.0.18. I update but can only update the version 3.0.19,
of if the error occurred at the second update:

# apt-get update && apt-get install globaleaks
Trovato:1 http://it.archive.ubuntu.com/ubuntu xenial InRelease
Trovato:2 http://it.archive.ubuntu.com/ubuntu xenial-updates InRelease
Trovato:3 http://it.archive.ubuntu.com/ubuntu xenial-backports InRelease
Trovato:4 http://security.ubuntu.com/ubuntu xenial-security InRelease
Trovato:5 http://deb.torproject.org/torproject.org xenial InRelease
Ign:6 http://deb.globaleaks.org xenial/ InRelease
Scaricamento di:7 http://deb.globaleaks.org xenial/ Release [1.501 B]
Scaricamento di:8 http://deb.globaleaks.org xenial/ Release.gpg [543 B]
Err:8 http://deb.globaleaks.org xenial/ Release.gpg
_ Le seguenti firme non erano valide: KEYEXPIRED 1523226483 KEYEXPIRED 1523226483 KEYEXPIRED 1523226483_
Recuperati 543 B in 1s (481 B/s)
Lettura elenco dei pacchetti… Fatto
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG erro r: http://deb.globaleaks.org xenial/ Release: Le seguenti firme non erano valide: KEYEXPIRED 1523226483 KEYEXPIRED 1523226483 KEYEXPIRE D 1523226483
W: Impossibile recuperare http://deb.globaleaks.org/xenial/Release.gpg Le seguenti firme non erano valide: KEYEXPIRED 1523226483 KEYEXP IRED 1523226483 KEYEXPIRED 1523226483
W: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli vecchi.
Lettura elenco dei pacchetti… Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato… Fatto
globaleaks is already the newest version (3.0.19).

other update mode this error:
wget https://deb.globaleaks.org/install-globaleaks.sh
chmod +x install-globaleaks.sh
./install-globaleaks.sh

# ./install-globaleaks.sh
Checking preliminary packaging GlobaLeaks requirements
_ + apt-key requirement met_
_ + apt-get requirement met_
Detected OS: Ubuntu - xenial
Running: “apt-get update -y”… SUCCESS
_ + curl requirement met_
_ + netstat requirement met_
Running: “is_tcp_sock_free_check 0.0.0.0:80”… FAIL
Ouch! The installation failed.
COMBINED STDOUT/STDERR OUTPUT OF FAILED COMMAND:
For Professional Support requests please visit: https://www.globaleaks.org/contact/
Please report encountered issues to the Community Forum at https://forum.globaleaks.org


#2

Hello to all,
i have fix the problem:
https://globaleaks.readthedocs.io/en/latest/UpgradeGuide.html#missing-or-expired-pgp-key

Thanks